Email sending not working

Incident Report for ntfy

Resolved

The email sending issue has been resolved. Email addresses now have to be verified before you can use them via the X-Email header. You can do so in the web app under "Account". I apologize for any inconveniences this may have caused.
Posted Mar 31, 2026 - 12:51 UTC

Identified

ntfy server v2.21.0: Email verification has been deployed and released to ntfy.sh. AWS SES support has been notified, and I expect the AWS SES account to be re-instated soon.

I added the email addresses of paid users to the database. Once the AWS account has been re-instated, others can add their own email addresses. Even free accounts can still send 5 emails per day, provided that the address was verified before.

The incident is still ongoing until the AWS account is unpaused.

https://github.com/binwiederhier/ntfy/releases/tag/v2.21.0
Posted Mar 31, 2026 - 00:12 UTC

Investigating

The email sending feature is currently not working. The ntfy AWS SES account was paused. I am investigating, but I'm expecting this disruption to take multiple days. Apologies.
Posted Mar 29, 2026 - 22:35 UTC
This incident affected: ntfy.sh API.